What’s Vulnerable › Vulnerabilities
CVE-2021-38539
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
Description
Certain NETGEAR devices are affected by privilege escalation. This affects D8500 before 1.0.3.44, R6400v2 before 1.0.2.66, R6700 before 1.0.2.6, R6700v3 before 1.0.2.66, R6900 before 1.0.2.4, R6900P before 1.3.2.126, R7000 before 1.0.9.42, R7000P before 1.3.2.126, R7100LG before 1.0.0.50, R7300DST before 1.0.0.70, R7900 before 1.0.3.10, R8300 before 1.0.2.130, and R8500 before 1.0.2.130.
Affected products
- NETGEAR D8500 Firmware: before 1.0.3.44 — fixed in 1.0.3.44
- NETGEAR R6400 Firmware: before 1.0.2.66 — fixed in 1.0.2.66
- NETGEAR R6700: before 1.0.2.6; before 1.0.2.66 — fixed in 1.0.2.6, 1.0.2.66
- NETGEAR R6900 Firmware: before 1.0.2.4 — fixed in 1.0.2.4
- NETGEAR R6900P Firmware: before 1.3.2.126 — fixed in 1.3.2.126
- NETGEAR R7000: before 1.0.9.42 — fixed in 1.0.9.42
- NETGEAR R7000P: before 1.3.2.126 — fixed in 1.3.2.126
- NETGEAR R7100Lg Firmware: before 1.0.0.50 — fixed in 1.0.0.50
- NETGEAR R7300Dst Firmware: before 1.0.0.70 — fixed in 1.0.0.70
- NETGEAR R7900 Firmware: before 1.0.3.10 — fixed in 1.0.3.10
- NETGEAR R8300 Firmware: before 1.0.2.130 — fixed in 1.0.2.130
- NETGEAR R8500 Firmware: before 1.0.2.130 — fixed in 1.0.2.130
How to fix
Upgrade to a fixed version: NETGEAR D8500 Firmware 1.0.3.44; NETGEAR R6400 Firmware 1.0.2.66; NETGEAR R6700 1.0.2.6, 1.0.2.66; NETGEAR R6900 Firmware 1.0.2.4; NETGEAR R6900P Firmware 1.3.2.126; NETGEAR R7000 1.0.9.42; NETGEAR R7000P 1.3.2.126; NETGEAR R7100Lg Firmware 1.0.0.50; NETGEAR R7300Dst Firmware 1.0.0.70; NETGEAR R7900 Firmware 1.0.3.10; NETGEAR R8300 Firmware 1.0.2.130; NETGEAR R8500 Firmware 1.0.2.130. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000063760/Security-Advisory-for-Vertical-Privilege-Escalation-on-Some-Routers-and-Gateways-PSV-2018-0385
- https://kb.netgear.com/000063760/Security-Advisory-for-Vertical-Privilege-Escalation-on-Some-Routers-and-Gateways-PSV-2018-0385
Get alerted when CVE-2021-38539 or the next vulnerability affects your stack