What’s Vulnerable › Vulnerabilities
CVE-2021-38540: Apache Airflow: Variable Import endpoint missed authentication check
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 80.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-09 · updated 2026-06-17
- Weakness: CWE-269
Description
The variable import endpoint was not protected by authentication in Airflow >=2.0.0, <2.1.3. This allowed unauthenticated users to hit that endpoint to add/modify Airflow variables used in DAGs, potentially resulting in a denial of service, information disclosure or remote code execution. This issue affects Apache Airflow >=2.0.0, <2.1.3.
Affected products
- Apache Airflow: from 2.0.0 before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: Apache Airflow 2.1.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/rac2ed9118f64733e47b4f1e82ddc8c8020774698f13328ca742b03a2%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/rb34c3dd1a815456355217eef34060789f771b6f77c3a3dec77de2064%40%3Cusers.airflow.apache.org%3E
- https://lists.apache.org/thread.html/rac2ed9118f64733e47b4f1e82ddc8c8020774698f13328ca742b03a2%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/rb34c3dd1a815456355217eef34060789f771b6f77c3a3dec77de2064%40%3Cusers.airflow.apache.org%3E
Get alerted when CVE-2021-38540 or the next vulnerability affects your stack