What’s Vulnerable › Vulnerabilities
CVE-2021-38569
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-674
Description
An issue was discovered in Foxit Reader and PhantomPDF before 10.1.4. It allows stack consumption via recursive function calls during the handling of XFA forms or link objects.
Affected products
- Foxit Reader: before 10.1.4 — fixed in 10.1.4
- Foxit PhantomPDF: before 10.1.4 — fixed in 10.1.4
How to fix
Upgrade to a fixed version: Foxit Reader 10.1.4; Foxit PhantomPDF 10.1.4. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2021-38569 or the next vulnerability affects your stack