What’s Vulnerable › Vulnerabilities
CVE-2021-3857: Cross-site Scripting (XSS) - Stored in chaskiq/chaskiq
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
chaskiq is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- Chaskiq: before 0.9.8 — fixed in 0.9.8
How to fix
Upgrade to a fixed version: Chaskiq 0.9.8. Check the vendor advisory for mitigations.
References
- https://github.com/chaskiq/chaskiq/commit/bffa585862b11cc05229ab3ed621d68f70ed33d0
- https://huntr.dev/bounties/18f7eaee-6309-40cb-aed3-d5ac0af03cf3
- https://github.com/chaskiq/chaskiq/commit/bffa585862b11cc05229ab3ed621d68f70ed33d0
- https://huntr.dev/bounties/18f7eaee-6309-40cb-aed3-d5ac0af03cf3
Get alerted when CVE-2021-3857 or the next vulnerability affects your stack