What’s Vulnerable › Vulnerabilities
CVE-2021-38570
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-59
Description
An issue was discovered in Foxit Reader and PhantomPDF before 10.1.4. It allows attackers to delete arbitrary files (during uninstallation) via a symlink.
Affected products
- Foxit Reader: before 10.1.4 — fixed in 10.1.4
- Foxit PhantomPDF: before 10.1.4 — fixed in 10.1.4
How to fix
Upgrade to a fixed version: Foxit Reader 10.1.4; Foxit PhantomPDF 10.1.4. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2021-38570 or the next vulnerability affects your stack