What’s Vulnerable › Vulnerabilities
CVE-2021-38589
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
Description
In cPanel before 96.0.13, scripts/fix-cpanel-perl does not properly restrict the overwriting of files (SEC-588).
Affected products
- WebPros cPanel: before 11.96.0.13 — fixed in 11.96.0.13
How to fix
Upgrade to a fixed version: WebPros cPanel 11.96.0.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-38589 or the next vulnerability affects your stack