What’s Vulnerable › Vulnerabilities
CVE-2021-3862: Cross-site Scripting (XSS) - Reflected in icecoder/icecoder
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
icecoder is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- ICEcoder: before 8.1 — fixed in 8.1
How to fix
Upgrade to a fixed version: ICEcoder 8.1. Check the vendor advisory for mitigations.
References
- https://github.com/icecoder/icecoder/commit/51cf24b2a39138e6a7b5739ef59eb38cd7c39763
- https://huntr.dev/bounties/5c9c228e-2a39-4643-bb82-2b02a2b0a601
- https://github.com/icecoder/icecoder/commit/51cf24b2a39138e6a7b5739ef59eb38cd7c39763
- https://huntr.dev/bounties/5c9c228e-2a39-4643-bb82-2b02a2b0a601
Get alerted when CVE-2021-3862 or the next vulnerability affects your stack