What’s Vulnerable › Vulnerabilities
CVE-2021-38680: Reflected XSS in Kazoo Server
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-29 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running Kazoo Server. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of Kazoo Server: Kazoo Server 4.11.20 and later
Affected products
- Linn Products Limited Kazoo Server: before 4.11.20 — fixed in 4.11.20
How to fix
Upgrade to a fixed version: Linn Products Limited Kazoo Server 4.11.20. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-21-54
- https://www.qnap.com/en/security-advisory/qsa-21-54
Get alerted when CVE-2021-38680 or the next vulnerability affects your stack