What’s Vulnerable › Vulnerabilities
CVE-2021-38689: Stack Overflow Vulnerability in QVR Elite, QVR Pro and QVR Guard
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-14 · updated 2026-06-17
- Weakness: CWE-120
Description
A stack buffer overflow vulnerability has been reported to affect QNAP device running QVR Elite, QVR Pro, QVR Guard. If exploited, this vulnerability allows attackers to execute arbitrary code. We have already fixed this vulnerability in the following versions of QVR Elite, QVR Pro, QVR Guard: QuTS hero h5.0.0: QVR Elite 2.1.4.0 (2021/12/06) and later QuTS hero h4.5.4: QVR Elite 2.1.4.0 (2021/12/06) and later QTS 5.0.0: QVR Elite 2.1.4.0 (2021/12/06) and later QTS 4.5.4: QVR Elite 2.1.4.0 (2021/12/06) and later QTS 4.5.4: QVR Pro 2.1.3.0 (2021/12/06) and later QTS 5.0.0: QVR Pro 2.1.3.0 (2021/12/06) and later QTS 4.5.4: QVR Guard 2.1.3.0 (2021/12/06) and later QTS 5.0.0: QVR Guard 2.1.3.0 (2021/12/06) and later
Affected products
- QNAP Systems Inc. QVR Elite: before 2.1.4.0 — fixed in 2.1.4.0
- QNAP Systems Inc. QVR Guard: before 2.1.3.0 — fixed in 2.1.3.0
- QNAP Systems Inc. QVR Pro: before 2.1.3.0 — fixed in 2.1.3.0
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QVR Elite 2.1.4.0; QNAP Systems Inc. QVR Guard 2.1.3.0; QNAP Systems Inc. QVR Pro 2.1.3.0. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-21-59
- https://www.qnap.com/en/security-advisory/qsa-21-59
Get alerted when CVE-2021-38689 or the next vulnerability affects your stack