What’s Vulnerable › Vulnerabilities
CVE-2021-3878: Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-15 · updated 2026-06-17
- Weakness: CWE-611
Description
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
Affected products
- stanfordnlp/corenlp: before 4.3.1 — fixed in 4.3.1
How to fix
Upgrade to a fixed version: stanfordnlp/corenlp 4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/stanfordnlp/corenlp/commit/e5bbe135a02a74b952396751ed3015e8b8252e99
- https://huntr.dev/bounties/a11c889b-ccff-4fea-9e29-963a23a63dd2
- https://github.com/stanfordnlp/corenlp/commit/e5bbe135a02a74b952396751ed3015e8b8252e99
- https://huntr.dev/bounties/a11c889b-ccff-4fea-9e29-963a23a63dd2
Get alerted when CVE-2021-3878 or the next vulnerability affects your stack