What’s Vulnerable › Vulnerabilities
CVE-2021-3879: Cross-site Scripting (XSS) - Stored in snipe/snipe-it
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-19 · updated 2026-06-17
- Weakness: CWE-79
Description
snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- grokability snipe-it: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: grokability snipe-it 5.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/snipe/snipe-it/commit/bda23bb1e66fd7ce42c75c69cf5eea4e80865c1c
- https://huntr.dev/bounties/6dccc49e-3843-4a4a-b397-5c659e5f8bfe
- https://github.com/snipe/snipe-it/commit/bda23bb1e66fd7ce42c75c69cf5eea4e80865c1c
- https://huntr.dev/bounties/6dccc49e-3843-4a4a-b397-5c659e5f8bfe
Get alerted when CVE-2021-3879 or the next vulnerability affects your stack