What’s Vulnerable › Vulnerabilities
CVE-2021-38927: IBM Aspera Console cross-site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-25 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Aspera Console 3.4.0 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 210322.
Affected products
- IBM Aspera Console: before 3.4.2; 3.4.2, 3.4.2-patch_level_1, 3.4.2-patch_level_2, 3.4.2-patch_level_3, 3.4.2-patch_level_4, 3.4.2-patch_level_5 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: IBM Aspera Console 3.4.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/210322
- https://www.ibm.com/support/pages/node/7101252
- https://exchange.xforce.ibmcloud.com/vulnerabilities/210322
- https://www.ibm.com/support/pages/node/7101252
Get alerted when CVE-2021-38927 or the next vulnerability affects your stack