What’s Vulnerable › Vulnerabilities
CVE-2021-38949
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-16 · updated 2026-06-17
- Weakness: CWE-312
Description
IBM MQ 7.5, 8.0, 9.0 LTS, 9.1 CD, and 9.1 LTS stores user credentials in plain clear text which can be read by a local user. IBM X-Force ID: 211403.
Affected products
- IBM MQ: from 8.0.0.0 before 8.0.0.14; from 9.0.0.0 before 9.0.0.9; from 9.1.0 before 9.1.5; from 9.1.0.0 before 9.1.0.5 — fixed in 8.0.0.14, 9.0.0.9, 9.1.0.5, 9.1.5
- IBM Corporation WebSphere MQ: 7.5
How to fix
Upgrade to a fixed version: IBM MQ 8.0.0.14, 9.0.0.9, 9.1.0.5, 9.1.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/211403
- https://www.ibm.com/support/pages/node/6516424
- https://exchange.xforce.ibmcloud.com/vulnerabilities/211403
- https://www.ibm.com/support/pages/node/6516424
Get alerted when CVE-2021-38949 or the next vulnerability affects your stack