What’s Vulnerable › Vulnerabilities
CVE-2021-3903: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-27 · updated 2026-06-17
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 33, 34, 35
- vim/vim: before 8.2.3564 — fixed in 8.2.3564
How to fix
Upgrade to a fixed version: vim/vim 8.2.3564. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/777e7c21b7627be80961848ac560cb0a9978ff43
- https://huntr.dev/bounties/35738a4f-55ce-446c-b836-2fb0b39625f8
- https://lists.debian.org/debian-lts-announce/2022/06/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BN4EX7BPQU7RP6PXCNCSDORUZBXQ4JUH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DU26T75PYA3OF7XJGNKMT2ZCQEU4UKP5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/777e7c21b7627be80961848ac560cb0a9978ff43
- https://huntr.dev/bounties/35738a4f-55ce-446c-b836-2fb0b39625f8
- https://lists.debian.org/debian-lts-announce/2022/06/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BN4EX7BPQU7RP6PXCNCSDORUZBXQ4JUH/
Get alerted when CVE-2021-3903 or the next vulnerability affects your stack