What’s Vulnerable › Vulnerabilities
CVE-2021-39035
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Sterling B2B Integrator Standard Edition 6.0.0.0 through 6.0.3.5, 6.1.0.0 through 6.1.0.4, and 6.1.1.0 through 6.1.1.1 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 213965.
Affected products
- IBM Sterling B2B Integrator: from 6.0.0.0 before 6.0.3.6; from 6.1.0.0 before 6.1.0.5; from 6.1.1.0 before 6.1.1.2 — fixed in 6.0.3.6, 6.1.0.5, 6.1.1.2
How to fix
Upgrade to a fixed version: IBM Sterling B2B Integrator 6.0.3.6, 6.1.0.5, 6.1.1.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/213965
- https://www.ibm.com/support/pages/node/6612499
- https://exchange.xforce.ibmcloud.com/vulnerabilities/213965
- https://www.ibm.com/support/pages/node/6612499
Get alerted when CVE-2021-39035 or the next vulnerability affects your stack