What’s Vulnerable › Vulnerabilities
CVE-2021-39038
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-1021
Description
IBM WebSphere Application Server 9.0 and IBM WebSphere Application Server Liberty 17.0.0.3 through 22.0.0.2 could allow a remote attacker to hijack the clicking action of the victim. By persuading a victim to visit a malicious Web site, a remote attacker could exploit this vulnerability to hijack the victim's click actions and possibly launch further attacks against the victim. IBM X-Force ID: 213968.
Affected products
- IBM WebSphere Application Server: from 9.0.0.0 before 9.0.5.12; from 17.0.0.3 through 22.0.0.2 — fixed in 9.0.5.12
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 9.0.5.12. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/213968
- https://www.ibm.com/support/pages/node/6559044
- https://exchange.xforce.ibmcloud.com/vulnerabilities/213968
- https://www.ibm.com/support/pages/node/6559044
Get alerted when CVE-2021-39038 or the next vulnerability affects your stack