What’s Vulnerable › Vulnerabilities
CVE-2021-3904: Cross-site Scripting (XSS) - Stored in getgrav/grav
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-27 · updated 2026-06-17
- Weakness: CWE-79
Description
grav is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- getgrav grav: before 1.7.24 — fixed in 1.7.24
How to fix
Upgrade to a fixed version: getgrav grav 1.7.24. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/afc69a3229bb6fe120b2c1ea27bc6f196ed7284d
- https://huntr.dev/bounties/b1182515-d911-4da9-b4f7-b4c341a62a8d
- https://github.com/getgrav/grav/commit/afc69a3229bb6fe120b2c1ea27bc6f196ed7284d
- https://huntr.dev/bounties/b1182515-d911-4da9-b4f7-b4c341a62a8d
Get alerted when CVE-2021-3904 or the next vulnerability affects your stack