What’s Vulnerable › Vulnerabilities
CVE-2021-3908: Infinite certificate chain depth results in OctoRPKI running forever
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-11 · updated 2026-06-17
- Weakness: CWE-400
Description
OctoRPKI does not limit the depth of a certificate chain, allowing for a CA to create children in an ad-hoc fashion, thereby making tree traversal never end.
Affected products
- Cloudflare octorpki: before 1.3.0 — fixed in 1.3.0
- Debian Linux: 11.0
How to fix
Upgrade to a fixed version: Cloudflare octorpki 1.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/cloudflare/cfrpki/security/advisories/GHSA-g5gj-9ggf-9vmq
- https://www.debian.org/security/2022/dsa-5041
- https://github.com/cloudflare/cfrpki/security/advisories/GHSA-g5gj-9ggf-9vmq
- https://www.debian.org/security/2022/dsa-5041
Get alerted when CVE-2021-3908 or the next vulnerability affects your stack