What’s Vulnerable › Vulnerabilities
CVE-2021-39114
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-05 · updated 2026-06-17
- Weakness: CWE-94
Description
Affected versions of Atlassian Confluence Server and Data Center allow users with a valid account on a Confluence Data Center instance to execute arbitrary Java code or run arbitrary system commands by injecting an OGNL payload. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.
Affected products
- Atlassian Confluence Data Center: before 6.13.23; from 6.14.0 before 7.4.11; from 7.5.0 before 7.11.6; from 7.12.0 before 7.12.5 — fixed in 6.13.23, 7.11.6, 7.12.5, 7.4.11
- Atlassian Confluence Data Center: before 6.13.23; from 6.14.0 before 7.4.11; from 7.5.0 before 7.11.6; from 7.12.0 before 7.12.5 — fixed in 6.13.23, 7.11.6, 7.12.5, 7.4.11
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 6.13.23, 7.11.6, 7.12.5, 7.4.11; Atlassian Confluence Data Center 6.13.23, 7.11.6, 7.12.5, 7.4.11. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-68844
- https://jira.atlassian.com/browse/CONFSERVER-68844
Get alerted when CVE-2021-39114 or the next vulnerability affects your stack