What’s Vulnerable › Vulnerabilities
CVE-2021-39132: YAML deserialization can run untrusted code
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-502
Description
Rundeck is an open source automation service with a web console, command line tools and a WebAPI. Prior to version 3.3.14 and version 3.4.3, an authorized user can upload a zip-format plugin with a crafted plugin.yaml, or a crafted aclpolicy yaml file, or upload an untrusted project archive with a crafted aclpolicy yaml file, that can cause the server to run untrusted code on Rundeck Community or Enterprise Edition. An authenticated user can make a POST request, that can cause the server to run untrusted code on Rundeck Enterprise Edition. The zip-format plugin issues requires authentication and authorization to these access levels, and affects all Rundeck editions:`admin` level access to the `system` resource type. The ACL Policy yaml file upload issues requires authentication and authorization to these access levels, and affects all Rundeck editions: `create` `update` or `admin` level access to a `project_acl` resource, and/or`create` `update` or `admin` level access to the `system_acl` resource. The unauthorized POST request requires authentication, but no specific authorization, and affects Rundeck Enterprise only. Patches are available in versions 3.4.3, 3.3.14
Affected products
- rundeck: before 3.3.14; from 3.4.0 before 3.4.3 — fixed in 3.3.14, 3.4.3
How to fix
Upgrade to a fixed version: rundeck 3.3.14, 3.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/rundeck/rundeck/commit/850d12e21d22833bc148b7f458d7cb5949f829b6
- https://github.com/rundeck/rundeck/security/advisories/GHSA-q4rf-3fhx-88pf
- https://github.com/rundeck/rundeck/commit/850d12e21d22833bc148b7f458d7cb5949f829b6
- https://github.com/rundeck/rundeck/security/advisories/GHSA-q4rf-3fhx-88pf
Get alerted when CVE-2021-39132 or the next vulnerability affects your stack