What’s Vulnerable › Vulnerabilities
CVE-2021-3914
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-25 · updated 2026-06-17
- Weakness: CWE-79
Description
It was found that the smallrye health metrics UI component did not properly sanitize some user inputs. An attacker could use this flaw to conduct cross-site scripting attacks.
Affected products
- Red Hat build of Quarkus: before 2.7.5 — fixed in 2.7.5
- RedHat Openshift Application Runtimes: 1.0
- RedHat Smallrye Health: all versions
How to fix
Upgrade to a fixed version: Red Hat build of Quarkus 2.7.5. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2021-3914
- https://bugzilla.redhat.com/show_bug.cgi?id=2018015
- https://access.redhat.com/security/cve/CVE-2021-3914
- https://bugzilla.redhat.com/show_bug.cgi?id=2018015
Get alerted when CVE-2021-3914 or the next vulnerability affects your stack