What’s Vulnerable › Vulnerabilities
CVE-2021-39143: Path Traversal in spinnaker
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-04 · updated 2026-06-17
- Weakness: CWE-22
Description
Spinnaker is an open source, multi-cloud continuous delivery platform. A path traversal vulnerability was discovered in uses of TAR files by AppEngine for deployments. This uses a utility to extract files locally for deployment without validating the paths in that deployment don't override system files. This would allow an attacker to override files on the container, POTENTIALLY introducing a MITM type attack vector by replacing libraries or injecting wrapper files. Users are advised to update as soon as possible. For users unable to update disable Google AppEngine deployments and/or disable artifacts that provide TARs.
Affected products
- spinnaker: before 1.24.7; from 1.25.0 before 1.25.7; from 1.26.0 before 1.26.7 — fixed in 1.24.7, 1.25.7, 1.26.7
How to fix
Upgrade to a fixed version: spinnaker 1.24.7, 1.25.7, 1.26.7. Check the vendor advisory for mitigations.
References
- https://github.com/spinnaker/spinnaker/security/advisories/GHSA-34jx-3vmr-56v8
- https://github.com/spinnaker/spinnaker/security/advisories/GHSA-34jx-3vmr-56v8
Get alerted when CVE-2021-39143 or the next vulnerability affects your stack