What’s Vulnerable › Vulnerabilities
CVE-2021-39158: Dependency injection in NVCaffe
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-23 · updated 2026-06-17
- Weakness: CWE-345
Description
NVCaffe's python required dependencies list used to contain `gfortran`version prior to 0.17.4, entry which does not exist in the repository pypi.org. An attacker could potentially have posted malicious files to pypi.org causing a user to install it within NVCaffe.
Affected products
- NVIDIA caffe: before 0.17.4 — fixed in 0.17.4
How to fix
Upgrade to a fixed version: NVIDIA caffe 0.17.4. Check the vendor advisory for mitigations.
References
- https://github.com/NVIDIA/caffe/security/advisories/GHSA-fmpp-8pwg-vwh9
- https://github.com/NVIDIA/caffe/security/advisories/GHSA-fmpp-8pwg-vwh9
Get alerted when CVE-2021-39158 or the next vulnerability affects your stack