What’s Vulnerable › Vulnerabilities
CVE-2021-39159: Remote code execution in Binderhub
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-25 · updated 2026-06-17
- Weakness: CWE-94
Description
BinderHub is a kubernetes-based cloud service that allows users to share reproducible interactive computing environments from code repositories. In affected versions a remote code execution vulnerability has been identified in BinderHub, where providing BinderHub with maliciously crafted input could execute code in the BinderHub context, with the potential to egress credentials of the BinderHub deployment, including JupyterHub API tokens, kubernetes service accounts, and docker registry credentials. This may provide the ability to manipulate images and other user created pods in the deployment, with the potential to escalate to the host depending on the underlying kubernetes configuration. Users are advised to update to version 0.2.0-n653. If users are unable to update they may disable the git repo provider by specifying the `BinderHub.repo_providers` as a workaround.
Affected products
- jupyterhub binderhub: before 0.2.0-n653 — fixed in 0.2.0-n653
How to fix
Upgrade to a fixed version: jupyterhub binderhub 0.2.0-n653. Check the vendor advisory for mitigations.
References
- https://github.com/jupyterhub/binderhub/commit/195caac172690456dcdc8cc7a6ca50e05abf8182.patch
- https://github.com/jupyterhub/binderhub/security/advisories/GHSA-9jjr-qqfp-ppwx
- https://github.com/jupyterhub/binderhub/commit/195caac172690456dcdc8cc7a6ca50e05abf8182.patch
- https://github.com/jupyterhub/binderhub/security/advisories/GHSA-9jjr-qqfp-ppwx
Get alerted when CVE-2021-39159 or the next vulnerability affects your stack