What’s Vulnerable › Vulnerabilities
CVE-2021-39167: TimelockController vulnerability in OpenZeppelin Contracts
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-27 · updated 2026-06-17
- Weakness: CWE-269
Description
OpenZepplin is a library for smart contract development. In affected versions a vulnerability in TimelockController allowed an actor with the executor role to escalate privileges. Further details about the vulnerability will be disclosed at a later date. As a workaround revoke the executor role from accounts not strictly under the team's control. We recommend revoking all executors that are not also proposers. When applying this mitigation, ensure there is at least one proposer and executor remaining.
Affected products
- openzeppelin-contracts: from 3.3.0 before 3.4.2; from 4.0.0 before 4.3.1 — fixed in 3.4.2, 4.3.1
How to fix
Upgrade to a fixed version: openzeppelin-contracts 3.4.2, 4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/blob/master/CHANGELOG.md#431
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/cec4f2ef57495d8b1742d62846da212515d99dd5
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-fg47-3c2x-m2wr
- https://github.com/OpenZeppelin/openzeppelin-contracts/blob/master/CHANGELOG.md#431
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/cec4f2ef57495d8b1742d62846da212515d99dd5
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-fg47-3c2x-m2wr
Get alerted when CVE-2021-39167 or the next vulnerability affects your stack