What’s Vulnerable › Vulnerabilities
CVE-2021-39177: User impersonation due to incorrect handling of the login JWT
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-287
Description
Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Versions of Geyser prior to 1.4.2-SNAPSHOT allow anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any user. Version 1.4.2-SNAPSHOT contains a patch for the issue. There are no known workarounds aside from upgrading.
Affected products
- GeyserMC Geyser: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: GeyserMC Geyser 1.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/GeyserMC/Geyser/commit/b9541505af68ac7b7c093206ac7b1ba88957a5a6
- https://github.com/GeyserMC/Geyser/security/advisories/GHSA-h77f-xxx7-4858
- https://updates.playhive.com/weekend-maintenance-disclosure-2kJMaY
- https://github.com/GeyserMC/Geyser/commit/b9541505af68ac7b7c093206ac7b1ba88957a5a6
- https://github.com/GeyserMC/Geyser/security/advisories/GHSA-h77f-xxx7-4858
- https://updates.playhive.com/weekend-maintenance-disclosure-2kJMaY
Get alerted when CVE-2021-39177 or the next vulnerability affects your stack