What’s Vulnerable › Vulnerabilities
CVE-2021-39187: Crash server with query parameter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-02 · updated 2026-06-17
- Weakness: CWE-74
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to version 4.10.3, Parse Server crashes when if a query request contains an invalid value for the `explain` option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch. There is a patch for this issue in version 4.10.3. No workarounds aside from upgrading are known to exist.
Affected products
- parse-community parse-server: before 4.10.3 — fixed in 4.10.3
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/308668c89474223e2448be92d6823b52c1c313ec
- https://github.com/parse-community/parse-server/releases/tag/4.10.3
- https://github.com/parse-community/parse-server/security/advisories/GHSA-xqp8-w826-hh6x
- https://jira.mongodb.org/browse/NODE-3463
- https://github.com/parse-community/parse-server/commit/308668c89474223e2448be92d6823b52c1c313ec
- https://github.com/parse-community/parse-server/releases/tag/4.10.3
- https://github.com/parse-community/parse-server/security/advisories/GHSA-xqp8-w826-hh6x
- https://jira.mongodb.org/browse/NODE-3463
Get alerted when CVE-2021-39187 or the next vulnerability affects your stack