What’s Vulnerable › Vulnerabilities
CVE-2021-39192: Privilege escalation: all users can access Admin-level API keys
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-03 · updated 2026-06-17
- Weakness: CWE-200
Description
Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.
Affected products
- TryGhost Ghost: from 4.0.0 before 4.10.0 — fixed in 4.10.0
How to fix
Upgrade to a fixed version: TryGhost Ghost 4.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/TryGhost/Ghost/releases/tag/v4.10.0
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5c
- https://github.com/TryGhost/Ghost/releases/tag/v4.10.0
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5c
Get alerted when CVE-2021-39192 or the next vulnerability affects your stack