What’s Vulnerable › Vulnerabilities
CVE-2021-39199: Cross site scripting via unsafe defaults in remark-html
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-06-17
- Weakness: CWE-79
Description
remark-html is an open source nodejs library which compiles Markdown to HTML. In affected versions the documentation of remark-html has mentioned that it was safe by default. In practice the default was never safe and had to be opted into. That is, user input was not sanitized. This means arbitrary HTML can be passed through leading to potential XSS attacks. The problem has been patched in 13.0.2 and 14.0.1: `remark-html` is now safe by default, and the implementation matches the documentation. On older affected versions, pass `sanitize: true` if you cannot update.
Affected products
- remarkjs remark-html: before 13.0.2; from 14.0.0 before 14.0.1 — fixed in 13.0.2, 14.0.1
How to fix
Upgrade to a fixed version: remarkjs remark-html 13.0.2, 14.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/remarkjs/remark-html/commit/b75c9dde582ad87ba498e369c033dc8a350478c1
- https://github.com/remarkjs/remark-html/releases/tag/14.0.1
- https://github.com/remarkjs/remark-html/security/advisories/GHSA-9q5w-79cv-947m
- https://www.npmjs.com/package/remark-html
- https://github.com/remarkjs/remark-html/commit/b75c9dde582ad87ba498e369c033dc8a350478c1
- https://github.com/remarkjs/remark-html/releases/tag/14.0.1
- https://github.com/remarkjs/remark-html/security/advisories/GHSA-9q5w-79cv-947m
- https://www.npmjs.com/package/remark-html
Get alerted when CVE-2021-39199 or the next vulnerability affects your stack