What’s Vulnerable › Vulnerabilities
CVE-2021-3920: Cross-site Scripting (XSS) - Stored in getgrav/grav-plugin-admin
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-19 · updated 2026-06-17
- Weakness: CWE-79
Description
grav-plugin-admin is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- getgrav grav-plugin-admin: before 1.10.25 — fixed in 1.10.25
How to fix
Upgrade to a fixed version: getgrav grav-plugin-admin 1.10.25. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav-plugin-admin/commit/6463135bf046d8131189c163158cd5db8f7a9675
- https://huntr.dev/bounties/ab564760-90c6-4e1d-80c2-852f45034cd1
- https://github.com/getgrav/grav-plugin-admin/commit/6463135bf046d8131189c163158cd5db8f7a9675
- https://huntr.dev/bounties/ab564760-90c6-4e1d-80c2-852f45034cd1
Get alerted when CVE-2021-3920 or the next vulnerability affects your stack