What’s Vulnerable › Vulnerabilities
CVE-2021-39200: Information Disclosure in wp_die() via JSONP in wordpress
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-09 · updated 2026-06-17
- Weakness: CWE-200
Description
WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions output data of the function wp_die() can be leaked under certain conditions, which can include data like nonces. It can then be used to perform actions on your behalf. This has been patched in WordPress 5.8.1, along with any older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.
Affected products
- Debian Linux: 10.0, 11.0
- WordPress: from 5.2 before 5.8.1 — fixed in 5.8.1
How to fix
Upgrade to a fixed version: WordPress 5.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-m9hc-7v5q-x8q5
- https://hackerone.com/reports/1142140
- https://www.debian.org/security/2021/dsa-4985
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-m9hc-7v5q-x8q5
- https://hackerone.com/reports/1142140
- https://www.debian.org/security/2021/dsa-4985
Get alerted when CVE-2021-39200 or the next vulnerability affects your stack