What’s Vulnerable › Vulnerabilities
CVE-2021-39201: Authenticated cross-site scripting (XSS) in WordPress editor
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress)
Affected products
- Debian Linux: 10.0, 11.0
- WordPress: from 5.0 before 5.8 — fixed in 5.8
How to fix
Upgrade to a fixed version: WordPress 5.8. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-wh69-25hr-h94v
- https://hackerone.com/reports/1142140
- https://www.debian.org/security/2021/dsa-4985
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-wh69-25hr-h94v
- https://hackerone.com/reports/1142140
- https://www.debian.org/security/2021/dsa-4985
Get alerted when CVE-2021-39201 or the next vulnerability affects your stack