What’s Vulnerable › Vulnerabilities
CVE-2021-39204: Excessive CPU usage in Pomerium
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-09 · updated 2026-06-17
- Weakness: CWE-834
Description
Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, incorrectly handles resetting of HTTP/2 streams with excessive complexity. This can lead to high CPU utilization when a large number of streams are reset. This can result in a DoS condition. Pomerium versions 0.14.8 and 0.15.1 contain an upgraded envoy binary with this vulnerability patched.
Affected products
- envoyproxy envoy: through 1.16.4; from 1.17.0 before 1.17.4; from 1.18.0 before 1.18.4; 1.19.0 — fixed in 1.17.4, 1.18.4
- pomerium: before 0.14.8; 0.15.0 — fixed in 0.14.8
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.17.4, 1.18.4; pomerium 0.14.8. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-3xh3-33v5-chcc
- https://github.com/pomerium/pomerium/security/advisories/GHSA-5wjf-62hw-q78r
- https://groups.google.com/g/envoy-announce/c/5xBpsEZZDfE/m/wD05NZBbAgAJ
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-3xh3-33v5-chcc
- https://github.com/pomerium/pomerium/security/advisories/GHSA-5wjf-62hw-q78r
- https://groups.google.com/g/envoy-announce/c/5xBpsEZZDfE/m/wD05NZBbAgAJ
Get alerted when CVE-2021-39204 or the next vulnerability affects your stack