What’s Vulnerable › Vulnerabilities
CVE-2021-39209: Bypassable CSRF protection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-15 · updated 2026-06-17
- Weakness: CWE-352
Description
GLPI is a free Asset and IT management software package. In versions prior to 9.5.6, a user who is logged in to GLPI can bypass Cross-Site Request Forgery (CSRF) protection in many places. This could allow a malicious actor to perform many actions on GLPI. This issue is fixed in version 9.5.6. There are no workarounds aside from upgrading.
Affected products
- glpi-project glpi: before 9.5.6 — fixed in 9.5.6
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/9.5.6
- https://github.com/glpi-project/glpi/security/advisories/GHSA-5qpf-32w7-c56p
- https://github.com/glpi-project/glpi/releases/tag/9.5.6
- https://github.com/glpi-project/glpi/security/advisories/GHSA-5qpf-32w7-c56p
Get alerted when CVE-2021-39209 or the next vulnerability affects your stack