What’s Vulnerable › Vulnerabilities
CVE-2021-39213: IP restriction on GLPI API Bypass with custom header injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-15 · updated 2026-06-17
- Weakness: CWE-74
Description
GLPI is a free Asset and IT management software package. Starting in version 9.1 and prior to version 9.5.6, GLPI with API Rest enabled is vulnerable to API bypass with custom header injection. This issue is fixed in version 9.5.6. One may disable API Rest as a workaround.
Affected products
- glpi-project glpi: from 9.1 before 9.5.6 — fixed in 9.5.6
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/9.5.6
- https://github.com/glpi-project/glpi/security/advisories/GHSA-6w9f-2m6g-5777
- https://github.com/glpi-project/glpi/releases/tag/9.5.6
- https://github.com/glpi-project/glpi/security/advisories/GHSA-6w9f-2m6g-5777
Get alerted when CVE-2021-39213 or the next vulnerability affects your stack