What’s Vulnerable › Vulnerabilities
CVE-2021-39214: Lacking Protection against HTTP Request Smuggling in mitmproxy
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-16 · updated 2026-06-17
- Weakness: CWE-444
Description
mitmproxy is an interactive, SSL/TLS-capable intercepting proxy. In mitmproxy 7.0.2 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This means that a malicious client/server could smuggle a request/response through mitmproxy as part of another request/response's HTTP message body. While a smuggled request is still captured as part of another request's body, it does not appear in the request list and does not go through the usual mitmproxy event hooks, where users may have implemented custom access control checks or input sanitization. Unless one uses mitmproxy to protect an HTTP/1 service, no action is required. The vulnerability has been fixed in mitmproxy 7.0.3 and above.
Affected products
- mitmproxy: through 7.0.2
References
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-22gh-3r9q-xf38
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-22gh-3r9q-xf38
Get alerted when CVE-2021-39214 or the next vulnerability affects your stack