What’s Vulnerable › Vulnerabilities
CVE-2021-39217: OpenMage LTS arbitrary command execution in custom layout update through blocks
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-77
Description
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.
Affected products
- OpenMage magento-lts: before 19.4.22; from 20.0.0 before 20.0.19 — fixed in 19.4.22, 20.0.19
How to fix
Upgrade to a fixed version: OpenMage magento-lts 19.4.22, 20.0.19. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/289bd4b4f53622138e3e5c2d2cef7502d780086f
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-c9q3-r4rv-mjm7
- https://github.com/OpenMage/magento-lts/commit/289bd4b4f53622138e3e5c2d2cef7502d780086f
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-c9q3-r4rv-mjm7
Get alerted when CVE-2021-39217 or the next vulnerability affects your stack