What’s Vulnerable › Vulnerabilities
CVE-2021-39221: XSS in Contacts
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Contacts application prior to version 4.0.3 was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Contacts application is upgraded to 4.0.3. As a workaround, one may use a browser that has support for Content-Security-Policy.
Affected products
- Nextcloud Contacts: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Nextcloud Contacts 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/contacts/pull/2407
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-j6cx-mxqf-f9vc
- https://github.com/nextcloud/contacts/pull/2407
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-j6cx-mxqf-f9vc
Get alerted when CVE-2021-39221 or the next vulnerability affects your stack