What’s Vulnerable › Vulnerabilities
CVE-2021-39222: XSS in Talk
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.
Affected products
- Nextcloud Talk: before 10.0.7; from 10.1.0 before 10.1.4; from 11.0.0 before 11.1.2 — fixed in 10.0.7, 10.1.4, 11.1.2
How to fix
Upgrade to a fixed version: Nextcloud Talk 10.0.7, 10.1.4, 11.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g
- https://github.com/nextcloud/spreed/pull/542
- https://hackerone.com/reports/1135481
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g
- https://github.com/nextcloud/spreed/pull/542
- https://hackerone.com/reports/1135481
Get alerted when CVE-2021-39222 or the next vulnerability affects your stack