What’s Vulnerable › Vulnerabilities
CVE-2021-39229: Regular expression deinal of service in apprise
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-400
Description
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is [here](https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359). The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.
Affected products
- caronc apprise: before 0.9.5.1 — fixed in 0.9.5.1
How to fix
Upgrade to a fixed version: caronc apprise 0.9.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359
- https://github.com/caronc/apprise/pull/436
- https://github.com/caronc/apprise/security/advisories/GHSA-qhmp-h54x-38qr
- https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359
- https://github.com/caronc/apprise/pull/436
- https://github.com/caronc/apprise/security/advisories/GHSA-qhmp-h54x-38qr
Get alerted when CVE-2021-39229 or the next vulnerability affects your stack