What’s Vulnerable › Vulnerabilities
CVE-2021-39261
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-06-17
- Weakness: CWE-787
Description
A crafted NTFS image can cause a heap-based buffer overflow in ntfs_compressed_pwrite in NTFS-3G < 2021.8.22.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Tuxera NTFS-3G: before 2021.8.22 — fixed in 2021.8.22
How to fix
Upgrade to a fixed version: Tuxera NTFS-3G 2021.8.22. Check the vendor advisory for mitigations.
References
- https://github.com/tuxera/ntfs-3g/releases
- https://github.com/tuxera/ntfs-3g/security/advisories/GHSA-q759-8j5v-q5jp
- https://lists.debian.org/debian-lts-announce/2021/11/msg00013.html
- https://security.gentoo.org/glsa/202301-01
- https://www.debian.org/security/2021/dsa-4971
- https://github.com/tuxera/ntfs-3g/releases
- https://github.com/tuxera/ntfs-3g/security/advisories/GHSA-q759-8j5v-q5jp
- https://lists.debian.org/debian-lts-announce/2021/11/msg00013.html
- https://security.gentoo.org/glsa/202301-01
- https://www.debian.org/security/2021/dsa-4971
Get alerted when CVE-2021-39261 or the next vulnerability affects your stack