What’s Vulnerable › Vulnerabilities
CVE-2021-3927: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-10-08
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 33, 34, 35
- vim/vim: before 8.2.3581 — fixed in 8.2.3581
How to fix
Upgrade to a fixed version: vim/vim 8.2.3581. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/0b5b06cb4777d1401fdf83e7d48d287662236e7e
- https://huntr.dev/bounties/9c2b2c82-48bb-4be9-ab8f-a48ea252d1b0
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BCQWPEY2AEYBELCMJYHYWYCD3PZVD2H7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PGW56Z6IN4UVM3E5RXXF4G7LGGTRBI5C/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/0b5b06cb4777d1401fdf83e7d48d287662236e7e
- https://huntr.dev/bounties/9c2b2c82-48bb-4be9-ab8f-a48ea252d1b0
Get alerted when CVE-2021-3927 or the next vulnerability affects your stack