What’s Vulnerable › Vulnerabilities
CVE-2021-3928: Use of Uninitialized Variable in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-10-08
- Weakness: CWE-457
Description
vim is vulnerable to Use of Uninitialized Variable
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 33, 34, 35
- vim/vim: before 8.2.3582 — fixed in 8.2.3582
How to fix
Upgrade to a fixed version: vim/vim 8.2.3582. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/15d9890eee53afc61eb0a03b878a19cb5672f732
- https://huntr.dev/bounties/29c3ebd2-d601-481c-bf96-76975369d0cd
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BCQWPEY2AEYBELCMJYHYWYCD3PZVD2H7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNXY7T5OORA7UJIMGSJBGHFMU6UZWS6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PGW56Z6IN4UVM3E5RXXF4G7LGGTRBI5C/
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/15d9890eee53afc61eb0a03b878a19cb5672f732
- https://huntr.dev/bounties/29c3ebd2-d601-481c-bf96-76975369d0cd
Get alerted when CVE-2021-3928 or the next vulnerability affects your stack