What’s Vulnerable › Vulnerabilities
CVE-2021-39289
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-23 · updated 2026-06-17
- Weakness: CWE-522
Description
Certain NetModule devices have Insecure Password Handling (cleartext or reversible encryption), These models with firmware before 4.3.0.113, 4.4.0.111, and 4.5.0.105 are affected: NB800, NB1600, NB1601, NB1800, NB1810, NB2700, NB2710, NB2800, NB2810, NB3700, NB3701, NB3710, NB3711, NB3720, and NB3800.
Affected products
- Netmodule Router Software: before 4.3.0.113; from 4.4.0.0 before 4.4.0.111; from 4.5.0.0 before 4.5.0.105 — fixed in 4.3.0.113, 4.4.0.111, 4.5.0.105
How to fix
Upgrade to a fixed version: Netmodule Router Software 4.3.0.113, 4.4.0.111, 4.5.0.105. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2021/Aug/22
- https://www.netmodule.com
- http://seclists.org/fulldisclosure/2021/Aug/22
- https://www.netmodule.com
Get alerted when CVE-2021-39289 or the next vulnerability affects your stack