What’s Vulnerable › Vulnerabilities

CVE-2021-39293

Description

In archive/zip in Go before 1.16.8 and 1.17.x before 1.17.1, a crafted archive header (falsely designating that many files are present) can cause a NewReader or OpenReader panic. NOTE: this issue exists because of an incomplete fix for CVE-2021-33196.

Affected products

How to fix

Upgrade to a fixed version: Go 1.16.8, 1.17.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-39293 or the next vulnerability affects your stack