What’s Vulnerable › Vulnerabilities
CVE-2021-3930
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-193
Description
An off-by-one error was found in the SCSI device emulation in QEMU. It could occur while processing MODE SELECT commands in mode_sense_page() if the 'page' argument was set to MODE_PAGE_ALLS (0x3f). A malicious guest could use this flaw to potentially crash QEMU, resulting in a denial of service condition.
Affected products
- Debian Linux: 9.0, 10.0
- QEMU: before 6.2.0 — fixed in 6.2.0
- RedHat Codeready Linux Builder: 8.0
- RedHat Codeready Linux Builder For Ibm Z Systems: 8.0
- RedHat Codeready Linux Builder For Power Little Endian: 8.0
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Advanced Virtualization Eus: 8.4
- RedHat Enterprise Linux For Ibm Z Systems: 8.0
- RedHat Enterprise Linux For Power Little Endian: 8.0
- OpenStack: 10, 13
How to fix
Upgrade to a fixed version: QEMU 6.2.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2020588
- https://lists.debian.org/debian-lts-announce/2022/04/msg00002.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20220225-0007/
- https://bugzilla.redhat.com/show_bug.cgi?id=2020588
- https://lists.debian.org/debian-lts-announce/2022/04/msg00002.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20220225-0007/
Get alerted when CVE-2021-3930 or the next vulnerability affects your stack