What’s Vulnerable › Vulnerabilities
CVE-2021-39317: AccessPress Themes - Authenticated Malicious File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-285
Description
A WordPress plugin and several WordPress themes developed by AccessPress Themes are vulnerable to malicious file uploads via the plugin_offline_installer AJAX action due to a missing capability check in the plugin_offline_installer_callback function found in the /demo-functions.php file or /welcome.php file of the affected products. The complete list of affected products and their versions are below: WordPress Plugin: AccessPress Demo Importer <=1.0.6 WordPress Themes: accesspress-basic <= 3.2.1 accesspress-lite <= 2.92 accesspress-mag <= 2.6.5 accesspress-parallax <= 4.5 accesspress-root <= 2.5 accesspress-store <= 2.4.9 agency-lite <= 1.1.6 arrival <= 1.4.2 bingle <= 1.0.4 bloger <= 1.2.6 brovy <= 1.3 construction-lite <= 1.2.5 doko <= 1.0.27 edict-lite <= 1.1.4 eightlaw-lite <= 2.1.5 eightmedi-lite <= 2.1.8 eight-sec <= 1.1.4 eightstore-lite <= 1.2.5 enlighten <= 1.3.5 fotography <= 2.4.0 opstore <= 1.4.3 parallaxsome <= 1.3.6 punte <= 1.1.2 revolve <= 1.3.1 ripple <= 1.2.0 sakala <= 1.0.4 scrollme <= 2.1.0 storevilla <= 1.4.1 swing-lite <= 1.1.9 the100 <= 1.1.2 the-launcher <= 1.3.2 the-monday <= 1.4.1 ultra-seven <= 1.2.8 uncode-lite <= 1.3.3 vmag <= 1.2.7 vmagazine-lite <= 1.3.5 vmagazine-news <= 1.0.5 wpparallax <= 2.0.6 wp-store <= 1.1.9 zigcy-baby <= 1.0.6 zigcy-cosmetics <= 1.0.5 zigcy-lite <= 2.0.9
Affected products
- AccessPress Themes Access Demo Importer (WordPress plugin): before 1.0.7 — fixed in 1.0.7
- AccessPress Themes accesspress-lite: through 2.92
- AccessPress Themes accesspress-mag: through 2.6.5
- AccessPress Themes accesspress-parallax: through 4.5
- AccessPress Themes accesspress-root: through 2.5
- AccessPress Themes accesspress-store: through 2.4.9
- AccessPress Themes Accesspress Basic: through 3.2.1
- AccessPress Themes agency-lite: through 1.1.6
- AccessPress Themes arrival: through 1.4.2
- AccessPress Themes Bingle: through 1.0.4
- AccessPress Themes Bloger: through 1.2.6
- AccessPress Themes brovy: through 1.3
- AccessPress Themes construction-lite: through 1.2.5
- AccessPress Themes Doko: through 1.0.27
- AccessPress Themes edict-lite: through 1.1.4
- Accesspressthemes Eight-Sec: through 1.1.4
- Accesspressthemes Eightlaw-Lite: through 2.1.5
- Accesspressthemes Eightmedi-Lite: through 2.1.8
- Accesspressthemes Eightstore-Lite: through 1.2.5
- AccessPress Themes Enlighten: through 1.3.5
- AccessPress Themes FotoGraphy: through 2.4.0
- AccessPress Themes opstore: through 1.4.3
- AccessPress Themes ParallaxSome: through 1.3.6
- AccessPress Themes Punte: through 1.1.2
- AccessPress Themes Revolve: through 1.3.1
- AccessPress Themes Ripple: through 1.2.0
- AccessPress Themes sakala: through 1.0.4
- AccessPress Themes ScrollMe: through 2.1.0
- AccessPress Themes StoreVilla: through 1.4.1
- AccessPress Themes swing-lite: through 1.1.9
How to fix
Upgrade to a fixed version: AccessPress Themes Access Demo Importer (WordPress plugin) 1.0.7. Check the vendor advisory for mitigations.
References
- https://patchstack.com/articles/authenticated-vulnerability-in-unpatched-wordpress-themes/
- https://plugins.trac.wordpress.org/changeset/2592642/access-demo-importer/trunk/inc/demo-functions.php
- https://plugins.trac.wordpress.org/changeset/2602132/access-demo-importer/trunk/inc/demo-functions.php
- https://www.wordfence.com/blog/2021/10/high-severity-vulnerability-patched-in-access-demo-importer-plugin/
- https://patchstack.com/articles/authenticated-vulnerability-in-unpatched-wordpress-themes/
- https://plugins.trac.wordpress.org/changeset/2592642/access-demo-importer/trunk/inc/demo-functions.php
- https://plugins.trac.wordpress.org/changeset/2602132/access-demo-importer/trunk/inc/demo-functions.php
- https://www.wordfence.com/blog/2021/10/high-severity-vulnerability-patched-in-access-demo-importer-plugin/
Get alerted when CVE-2021-39317 or the next vulnerability affects your stack