What’s Vulnerable › Vulnerabilities
CVE-2021-39322: Easy Social Icons <= 3.0.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Social Icons plugin <= 3.0.8 for WordPress echoes out the raw value of `$_SERVER['PHP_SELF']` in its main file. On certain configurations including Apache+modPHP this makes it possible to use it to perform a reflected Cross-Site Scripting attack by injecting malicious code in the request path.
Affected products
- cybernetikz Easy Social Icons: before 3.0.9 — fixed in 3.0.9
How to fix
Upgrade to a fixed version: cybernetikz Easy Social Icons 3.0.9. Check the vendor advisory for mitigations.
References
- https://wpvulndb.com/vulnerabilities/5e0bf0b6-9809-426b-b1d4-1fb653083b58
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39322
- https://wpvulndb.com/vulnerabilities/5e0bf0b6-9809-426b-b1d4-1fb653083b58
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39322
Get alerted when CVE-2021-39322 or the next vulnerability affects your stack