What’s Vulnerable › Vulnerabilities
CVE-2021-39342: Credova_Financial <= 1.4.8 Sensitive Information Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-29 · updated 2026-06-17
- Weakness: CWE-319
Description
The Credova_Financial WordPress plugin discloses a site's associated Credova API account username and password in plaintext via an AJAX action whenever a site user goes to checkout on a page that has the Credova Financing option enabled. This affects versions up to, and including, 1.4.8.
Affected products
- Credova Financial Credova_Financial: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: Credova Financial Credova_Financial 1.4.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2606811/credova-financial/trunk/credova-financial.php
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39342
- https://plugins.trac.wordpress.org/changeset/2606811/credova-financial/trunk/credova-financial.php
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39342
Get alerted when CVE-2021-39342 or the next vulnerability affects your stack