What’s Vulnerable › Vulnerabilities
CVE-2021-3935
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-22 · updated 2026-06-17
- Weakness: CWE-89
Description
When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 35
- PgBouncer: before 1.16.1 — fixed in 1.16.1
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: PgBouncer 1.16.1. Check the vendor advisory for mitigations.
References
- http://www.pgbouncer.org/changelog.html#pgbouncer-116x
- https://bugzilla.redhat.com/show_bug.cgi?id=2021251
- https://lists.debian.org/debian-lts-announce/2022/02/msg00016.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNPCV3KRDI5PLLLKADFVIOHACQJLZMLI/
- http://www.pgbouncer.org/changelog.html#pgbouncer-116x
- https://bugzilla.redhat.com/show_bug.cgi?id=2021251
- https://lists.debian.org/debian-lts-announce/2022/02/msg00016.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00032.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNPCV3KRDI5PLLLKADFVIOHACQJLZMLI/
Get alerted when CVE-2021-3935 or the next vulnerability affects your stack